Chapter 16 - Surface Editing Tools

It is not unusual for a project to require more detail than a surface generated by Roadway Designer can provide.
Nor is it unusual to need a surface that cannot be easily created using templates. A few of the many examples
that may require an additional level of detail include:

Intersections
Interchanges
Divided highways
Bridge abutments
Borrow pits
Pedestrian refuges
Ponds

Parking areas

Rather than try to build a final surface by using typical sections alone, then merging or running many corridors
at once to build a parking lot, for example, you can build breakline features for your surface using multiple
methods. With this approach, you can use a variety of tools to contribute to the model. Instead of trying to force
one workflow (e.g. Typical Sections and Modeling) to create everything, use individual commands designed
specifically to create or modify features, combining their resulting breaklines for your overall model.

Section Objectives:

To learn techniques for refining a design DTM, such as a composite model made up of
more than one design surface.

To accomplish project-specific design scenarios by manipulating individual features.

To learn how to manipulate features for grading in areas that don’t lend themselves to the
Roadway Modeling process, such as slopes around bridges, borrow pits or ponds.

To learn where the Surface Creation and Editing tools fit into the overall CDOT Design
process and how they can be used to your advantage.
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Locks
Lacks =]
Wnnamecb vI %I @ i

Before working with features, there are lock settings that should be understood: Feature Filter,
Feature Highlight, Pen/Pencil, Delete Ink, Locate Features / Locate Graphics and Point
Snap/Element Snap/No Snap. Suggestions on when to use each are listed below. For
additional details on the locks, see the InRoads Online Help.

Feature Filter

All Design Features -

Feature filters can be created to segregate the features listed in InRoads dialog boxes. For
example, you can create a filter based on any number of criteria, such as whether or not a
feature is triangulated. When you toggle on the lock, only features that meet the active filter
criteria are shown in dialogs, and therefore available for editing. This can be handy, for
example, when you are working with a surface containing hundreds or thousands of features,
but you only want to see/edit edges of oil. Set up a filter to look for only features with ‘oil’ in
the name, then toggle the lock on.

Filters are stored in your XIN file and standard filters already exist for your use.

Feature Highlight

=
)

When the Feature Highlight lock is toggled on, any command that includes a feature list field
will highlight the feature in plan view when it is selected in the list, whether it is displayed or
not. This is a good check to visually verify the feature you want to display and / or edit.

Important!  Turning on the Feature Highlight lock slows the opening of dialog boxes that
include feature lists.

Pen / Pencil

When the features you are editing are displayed with Pen/Pencil set to Pencil, the modified
features are kept ‘up-to-date’ in the graphics file. If set to Pen, original graphics are left in
place and modified features are added, resulting in multiple graphical copies of features,
although the DTM only contains the most recent update.

Delete Ink

When Delete Ink is toggled on, the Pen setting acts very much like Pencil, as all previous
versions (Pencil or Pen) of a feature are deleted when the feature is modified.

Page 434

Colorado Department of Transportation



A Practical Guide for Using InRoads XM Chapter 16 - Surface Editing Tools

Locate Graphics / Locate Features

[]

Several of the commands described in this chapter are dual purpose. They can create features or
they can create graphics. Likewise, they can use graphics or features as input. On most
commands, you will note this difference when you Apply the command and it prompts for
either features or elements, based on this lock’s setting. For others, the current Locate mode is
shown at the top of the dialog box, some also have a Generate Graphics Only toggle.

Point Snap

When using Partial Delete or Break Feature, the Point Snap limits the selected points to
existing points on the feature. In other words, no new points are added at the beginning and end
of the break. Element Snap has no effect on surface editing tools. For information on how the
snaps affect geometry, see the InRoads Online Help.

Feature Properties

B4 Feature Properties (=8l |
Surtace 12345 existing ground v Stle Appl
sature:
B_RAIL_Ty-10M o] [ ke |
Mare Sile - ﬂ B_RAIL_Tw10R
. B_RAIL_Ty-3 Filter.
T_Edge of Diiveway (Gravall6a3 T_Edge of Diiveway ERAL TeT
T_Edage of Driveway [Gravel)590 T_Edge of Driveway B_RAIL_Ty-7 SECT-A List Points...
T_Edgs of Diiveway [Gravel)B27 T_Edge of Drivaway Breakling
T_Edge of Diiveway [Gravel|228 T_Exdge of Diiveway Frimary: [ Hew Stye.. |
T_Edge of Gravel Fload T_Edge of Gravel Fic T_Edge of D1 Farking Lot o e
T_Edge of Gravel Road209 T_Edge of Gravel Ric 5 "
T_Edge of Landscaped &rea T_Edge of Landscap EBEEED
T_Edge of Landscaped AreaB71 T_Edge of Landscap
T_Edage of Oil Parking Lat T_Edae of Oil Parkim
T_Edge of Dil Parking LotB76 T_Edge of Oil Parkiry

T_Edge of 0il Parking Lota77
T_Edge of 0l Parking Lotaa3
T_Edge of Qill1E
T_Edge of D19
T_Edge of 0il123
T_Edge of OiN3
T_Edge of 015
«

I

T_Edge of Dil Parkiny
T_Edge of Oil Parking
T_Edge of Oil
T_Edae of Ol
T_Edge of Oil
T_Edae of Ol
T_Edge of Oil

M T_Edge of Oil Parking Lot

Description Edge of 0il Parking Lot

Parent:

Refresh/Display in 3-0/Plan Yiew

Fay ltems

Name Description From Style
Triangulation
Feature Type: Breskline e
Paint Density Intsrval o g ﬂ

Exclude from Triangulation

£

The Feature Properties command (Surface > Feature > Feature Properties) provides a
list of all of the features contained in the surface and the style assigned to each feature. Use this
dialog box for a variety of functions including:

e Changing feature properties like Name, Description, Point Type, Point Density Interval,

etc.

e Making a non-triangulating feature part of the triangulated network, or vice-versa.

e Assigning the feature a parent name or secondary style for filtering purposes.

In addition, you can select List Points to generate a report on basic feature information along
with the feature’s length and coordinate information for each vertex on the feature. This is
helpful when checking a feature’s elevation.

Note: Ifthe feature’s Style doesn’t exist in the current XIN, it will display red in the list.
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Creating Features

There are many options within InRoads that assist in CDOT’s design process besides typical sections and
roadway modeling. Using these tools, you can build surfaces from scratch or add to previously created surfaces
(design or existing).

Section Objectives:

e To be able to create new features from scratch.

e To develop an understanding of when each of the feature creation commands should be
used.

e To learn techniques that will help refine existing surface models by adding features.
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Import Surface from Graphics

MicroStation graphics can be imported into a surface to form features. If you are comfortable
drawing with MicroStation, you might find it useful to first draw what you want in the design
file, then import the graphics as features as opposed to creating the features from scratch. This
is especially useful in situations where the graphics are relatively simple, or when you want the
new feature to take on the elevations of a known surface so you do not have to worry about
setting the z-coordinate manually. You can also use this command to create a “flat” feature,
then use Generate Longitudinal Feature (GLF) to add elevations. See the Generate
Longitudinal Feature section in this chapter for details.

1. Draw the graphics with MicroStation.

2. Select File > Import > Surface > From Graphics.

Hl’mpor{ Surface =] & ==
From Graphics | DEM | Fram Geometry

Surface: 12345 Design Pond -

ALG_COGO_Paints
Besultz...

Elewvations: Uze Element Elevations —— ]
Preferences...

Intercept Surface: 12345 SHEE

Dirape Yertices Only I&I
Thin Surface
Tolerance: 500

Features
Usze Tagged Graphics Information

Seed Mame: Pond Bottam - ﬂ
Feature Style: H_Detention_Pond-Botta v

M aximum Segment Length: | 0.00
Paint Dengity Interval: 0.00

Duplicate Mames:
Append Replace @ Rename

Exclude from Triangulation

Cloze

3. Specify the Surface where the feature is being imported.

Note: Ifthe surface has not been created, you may type the name in and it will be created
when you Apply.

4. Specify the Load From option.

Note: To use a selection set, choose the Single option. When you Apply, you’ll be asked
if you want to use the active selection set.

See the InRoads Online Help for information on the other options in this dialog.

5. <D> Apply and follow the prompts to load your feature(s) into the surface.
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A Practical Guide for Using InRoads XM

Accessing Design Surface commands

While there are many commands in InRoads that create features, several of them are grouped
under Design Surface. You can access them from the Surface > Design Surface pull-
down menu, or from the Design Surface toolbar. Most are described in the following section.

Design Surface

2
SEANE | TH S Zh S

IMenu Bar =
File
[

Suface Geometry Drainage Evaluation Modeler Drafting Tools Help

Wiew Surface 3
ﬁ Update 3-D/Flan Surface Display...
Fit Surface

& Iriangulate Surface...

Design Surface L\\, ‘,I’° Flace Feature. ..

Dresign Pad | 17 Generate Transverse Feature...
Edit Surface v 1 Generate Longitudinal Feature. .
Feature 4 "\\3 Set Slope Along Feature. ..

=
B Surface Properties... s (e SiEee.,

?:' Fillet Features...

i Gererate Sloped Surface...
4 Apply Template...

~Z Set Elevation...

f@ Project Line to Surface...
é Generate |zopach Surface. ..

@ Active Surface...
:‘: LCopy Surface...
2 Delete Surface...
!2; Bename Surface...

LUtilities

A¥ Resurface...
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Generate Longitudinal Feature

Generate Longitudinal Feature (GLF) is used to create and/or modify 3D MicroStation
elements or features in a DTM. It is an extremely powerful tool that allows much easier
manipulation in 3D than MicroStation alone.

When using this command to create a new feature, one of the easiest methods is to draw the
feature in plan view with MicroStation without regard to the elevation, then use GLF to copy
the element, creating a feature while adding elevations at the same time.

In this example, a drain line is added to the bottom of a pond. The design calls for the drain to
start at a fixed elevation and proceed at a longitudinal grade along the prescribed route.

EL:5142

-1%

1. Use MicroStation to draw the drain line in the plan view.

2. Select Surface > Generate Longitudinal Feature.

HGenerateLongitudinalFeature =] & ==

Main | Cartrols

Surface: 12345 Design pond -
Exterior &rc: B ooon
Mew Style...
Reference Feature
V| Interval: 10.00 ﬂ ks

Stroke Tolerance: | 0,01

Longitudinal Feature

Mode: @ MNew Moty
Hame: Pond drain v ﬂ
Feature Style: | Breakline h |
Paint Type: | Breakline h |
Faint Density Interval: — 0.on ﬂ
Duplicate Mames:

Append Feplace @ Fename

Exclude from Triangulation

Femove Loops Generate Graphics Only

Triangulate Surface

Apply | | Freferences... | | Cloze
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The Main tab

1. Specify the Surface where a feature is being added or modified.

Note: The Exterior Arc is used when the new feature is horizontally offset from the original.

In this case, it is set to 57 When the copy is offset to the outside of a corner, the
resulting feature will fan out from the corner in 5 increments, giving the effect of a
fillet. The smaller the setting, the smoother the fillet.

Reference Feature

This category is for specifying how many vertices will be created in the resulting feature.
Either Interval, Stroke Tolerance or both must be toggled on.

Interval is a master-unit setting that determines how often along the reference feature or
element a new vertex is created.

1.

In this case, the Interval is toggled on and set to Z0. In general, this setting should
reflect a similar interval to the surrounding features. Here, the pond bottom has a
similar interval.

Toggle on Stroke Tolerance. This option has two functions:

o First, if the reference element contains a curve or arc, this setting is used to stroke
the curve or arc into a series of vertices. See the InRoads Online Help for more
information.

o Second, it ensures the creation of a vertex at each occurrence of a vertex in the
reference.

Longitudinal Feature

1.

Set the Mode to New.

Longitudinal Feature options are available or not depending upon two things:

o If Generate Graphics Only is toggled on or off — if on, several of the feature
settings do not apply, since only graphics result from the command. In this case, it
is toggled off.

o Ifthe Mode is New or Modify — if Modify, several of the feature settings do not
apply, as they are already established for the feature or element being modified.

Key in a Name for the new feature.
Assign the new feature a Feature Style.

Hint: If there is already a feature using the desired style, save time by selecting it as the
Name to populate the Feature Style field, then type over the name with your new one.

Select a Point Type from the drop-down.

For Point Density key in O.
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Note:

Note:

o

O

Point Density is a densification factor applied to the feature when it is triangulated.
Fixed vertices are not added to the feature using this option — but triangulation
vertices are. This setting can be added or changed after the fact in Feature
Properties.

The Duplicate Names area is only applicable if you have chosen a name that
already exists in the surface. The options are:

Append: The feature added is appended to the end of the named feature. As points
are added, there is rubberbanding in the graphics file to show which end of the
feature is being appended. If it is not the desired end, use Surface > Edit
Surface > Reverse Feature Direction to first change the orientation of the
original feature

Replace: The old feature is removed and the new one added in its place

Rename: A numeric suffix is added onto the name and used for the new feature

6. Toggle off Exclude from Triangulation.

Note: Toggle this option on if the feature is a utility, right-of-way, or some other

breakline that you want to show on profiles and cross sections but do not want
to affect the triangulation.

7. Toggle off Remove Loops.

Note: If Remove Loops is on, this option will remove the loops when you are

copying a feature or element with horizontal offsets that would result in loops
in interior corners.

8. Toggle off Triangulate Surface.

Note: Toggle on Triangulate Surface if it’s desired to see results of re-triangulation

after each feature is added or modified.
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The Controls Tab

On this tab, the horizontal and vertical location of the new or modified feature is set. For details
on each of the options, see the InRoads Online Help.

HGenerateLongitudinalFeature EI El @
Main | Controls
Horizontal
Method: Offset from Primary Feature |
Start Offset: 0.00 ﬂ
Stop Offset: 0.00 ﬂ
Wertical
Method: Elevation/Longitudinal Slope |
Start Elevation: 5142.00 ﬂ
Longitudinal Slope: -1.00%
| Apply | | Freferences... | | Cloze |

1. For the Horizontal Start and Stop Offsets key in O, since the drain line has been drawn in
the correct horizontal location.

2. Set the Vertical Method to Elevation/Longitudinal Slope. Here, the beginning of the drain
line starts at 5142 and will slope at -1%.

3. <D> Apply.

Note: You are prompted to identify Primary and Reference elements or features based on
the Locate Graphics / Locate Features lock settings. This lock may be toggled in
the middle of the command, so you can identify a Primary Feature, then toggle to
Locate Graphics and identify a Reference Element.

Remember, the Primary element or feature is what you are copying or modifying and the
Reference is for:

¢ Applying the interval
¢ Specifying what the result is perpendicular to, and
¢ Stroking

For a situation such as the drain line created here, the original element is both the Primary
and Reference.

4. <D> on the drain line for the Primary element and <D> to accept.

5. <D> on the drain line for the Reference element and <D> to accept.
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Note: Once the Primary and Reference are identified and accepted, the Identify
Location prompt is shown. When the copy or modification is horizontally offset, it
is necessary to <D> on the side of the desired result. When it’s not horizontally

offset, you can accept anywhere.
6. Since there is no horizontal in this case, <D> anywhere in the view to finalize the result.

7. View the triangles (Surface > View Surface > Triangles) and contours (Surface >
View Surface > Contours) to see the results.

Here, you’ll notice that there are triangles cutting across the corners, causing some erroneous
contours. See the process for Place Features in this chapter for a suggestion on how to combat
this situation and further enhance the surface.

Colorado Department of Transportation Page 443



Chapter 16 - Surface Editing Tools A Practical Guide for Using InRoads XM

Place Feature

The Place Feature command is used to create individual 3D features in a DTM. This is
useful in various situations, such as adding a utility to a DTM, controlling triangulation in a
specific area, or just adding a breakline for a portion of the design.

’E‘ Place Feature E@‘
Surface: 12345 Design pond - :
rz:::::[e Fond break. - ﬂ
Description: snerate Sloped Suface command
Feature Style: [Breakline v]
Praint Type: [ Breakline - ]

Duplicate Mames:
Append Replace @ Rename

[ Exelude from Triangulation

[ Triangulate Surface

Dynamics Settings and Intervals
[ Morthing/E asting: 0.00

[T Elevation: 0.00

[] Distance: 0.00

[] Direction: o oooa
[ Slope: 0.00%

In this example, a breakline is added to enhance the triangulation of a sloped bottom pond.
Notice how the contours do not follow the shape of the pond bottom in the corners.
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Displaying the triangles shows why; in the corners the triangles have all three points touching
the edge of the pond bottom, with nothing projecting to the drain line in the middle of the pond.
Breaklines can help resolve this issue, resulting in a better surface model.

1. Select Surface > Design Surface > Place Feature.

’ﬁ Place Feature E@@‘
Surface: 12345 Design pond -
rz:::::[e Pond break. hd ﬂ
D escription: =nerate Sloped Suface command
Feature Style: [Breakline v]
Point Type'  [Breakiine -

Duplicate Mames:
Append Feplace (@ Rename

[ Exelude from Triangulation

[ Triangulate Surface

Dynamics Settings and Intervals
[ Morthing/E asting: 0.00

[T Elevation: 0.00

[] Distance: 0.00

[] Direction: o oooa
[ Slope: 0.00%

2. Specify the Surface to add the feature to in the drop-down list.

Note: Ifitis a brand new surface, the name can be typed in here and the surface is created
when the command is applied.

Note: The Feature area of the dialog is automatically populated with information from
the first feature in the active surface. This is the area where the new feature

information is entered.
3. Either key in a Name or choose one from the drop-down.

Note: See the Duplicate Name information below regarding what happens if an existing
feature name is chosen.
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4. Enter a Description (optional).

5. Choose a Feature Style from the drop-down list that matches the feature being created.
These styles are stored in CDOT’s XIN file.

Hint: If there is already a feature using the desired style, save time by selecting it as the
Name to populate the Feature Style field, then type over the name with your new one.

6. Set the Point Type to Breakline.
¢ In general, this command is used to create breakline features, although you can also
create Random, Contour, Interior or Exterior features.
¢ Random features do not show up on cross sections or profiles.

Note: The Duplicate Names area is only applicable if you have chosen a name that
already exists in the surface.

o Append: The feature added is appended to the end of the named feature. As points
are added, there is rubberbanding in the graphics file to show which end of the
feature is being appended. If it is not the desired end, use Surface > Edit
Surface > Reverse Feature Direction to first change the orientation of the
original feature.

o Replace: The old feature is removed and the new one added in its place.

o Rename: A numeric suffix is added onto the name and used for the new feature.
7. Toggle off Exclude from Triangulation.

Note: Toggle this option on if the feature is a utility, right-of-way, or some other
breakline that you want to show on profiles and cross sections but do not want to
affect the triangulation.

8. Toggle off Triangulate Surface.

Note: Toggle this option on if it’s desired to see results of re-triangulation after each
feature is added.

9. Toggle off all options under Dynamic Settings and Intervals.

Note: These options are intervals, not actual values. For example, if you set the Distance
interval to Z00, the vertices of the feature being placed are locked into multiples
of 100 master units apart. This is useful if the breakline represents pipe that must
be placed in fixed lengths, for example.

10. <D> Apply to open the Set Elevation dialog box and begin the process of entering the
feature.
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The Set Elevation Box

A second dialog appears when the command is applied. This dialog allows the elevation of the
cursor to be overridden for each vertex.

’H Set Elevation @‘
Specify Elewvation: 0.00
Elevation from Surface: | 12345 Desion ¢
0.00

1. Toggle off both Specify Elevation and Elevation from Surface.

If you toggle on Specify Elevation the elevation of each vertex can be entered.

If you toggle on Elevation from Surface each vertex pulls its elevation from the listed
surface. This surface does not have to be the same as the to which the feature is being
added. An Elevation Adjustment is also allowed for adding the feature a specified
distance above or below the listed surface. This is useful for specifying coverage for a
utility.

¢ Ifyou leave both toggles off the elevations are taken from the cursor location
(element’s elevation if you snap to something or active depth if you do not).

2. Snap to the drain line end, then the pond bottom, to pick up the elevations and place the
feature.

Note: Additional features can be added as necessary.
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3. Triangulate the surface (Surface > Triangulate Surface) when done, and view the contours
to see any improvement.

This process is iterative and a choice must be made as to the value of continual refinement to
the DTM, the goal being not to pass the point of diminishing returns.
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Generate Transverse Feature

The Generate Transverse Feature command creates a new feature that consists of lines at
a specified interval connecting two known features. The lines are perpendicular to, and the
interval is specified along, a reference feature. You can also work in Graphics Only mode and
identify MicroStation elements as either of the known or the reference lines.

Transverse features are useful when triangulation is not forming the slopes between the two
known features as you need. For example, if one feature has less points that the other, there
may be large, irregular triangles formed, or if one or both of the known features have concave
areas where triangles are cutting across and touching only one of the features.

In the diagram below, notice the sideslopes in the fill area are created with triangles that are not
perpendicular to the centerline. This could happen in cases where you create the sideslope after
the backbone model is formed or when you’re using Surface Edit tools to create a new model.

——=]

i

1. Choose Surface > Design Surface > Generate Transverse Feature.

/H Generate Transverse Feature =& @‘
Surface: SH 86 -
Exterior &rc: 5000 T o |

Reference Feature —————————

2500 J Filter...

V| Shoke Tolerance: .01 Hew Style...
Freferences...

Transverse Feature .

Name: Trahsverse - J I&I

Feature Style: | Breakline - |

Point Type: | Breakline - |

Faint Density Interval:  0.on ﬂ

Duplicate Mames:

Append Fieplace Fiename

Exclude from Triangulation

Include Tick Marks Generate Graphics Only

Triangulate Surface

Colorado Department of Transportation Page 449



Chapter 16 - Surface Editing Tools A Practical Guide for Using InRoads XM

Specify the Surface to add the feature to in the drop-down list.

Note: Ifitis a brand new surface, the name can be typed in here and the surface is created
when the command is applied.

For Exterior Arc, key in 5.

Note: The Exterior Arc is used when the reference feature has exterior corners between
the two known features. In this case, it is set to 5. When the transverse feature is
created to the outside of a corner, the resulting feature lines will fan out from the
corner in 5” increments, giving the effect of a fillet. The smaller the setting, the
smoother the fillet.

Reference Feature

This category is for specifying at how many locations that transverse lines will be created in the
resulting feature. Either Interval, Stroke Tolerance or both must be toggled on.

4,

Set the interval to 25. In general, this setting should reflect a similar interval to the
surrounding features.

Note: Interval is a master-unit setting that determines how often along the reference
feature or element a new transverse line is created.

Toggle on Stroke Tolerance and set to 0.01.
Note: Stroke Tolerance has two functions:

¢ First, if the reference element is a curve or arc, this setting is used to stroke the curve or
arc into a series of vertices. See the InRoads Online Help for more information.

¢ Second, it ensures the creation of a vertex at each occurrence of a vertex in the
reference feature or element.

Toggle Generate Graphics Only off. If on, several of the feature settings do not apply since
only graphics result from the command.

Key in a new Name for the transverse feature you’re creating.

Choose a Feature Style that matches the feature being created. These styles are stored in
CDOT’s XIN file.

Hint: If there is already a feature using the desired style, select it as the Name to populate
the Feature Style field, and then type over the name with your new name.

Set the Point Type to Breakline.

¢ In general, this command is used to create breakline features, although you can also
create Random, Contour, Interior or Exterior features.

¢ Random feature do not show up on cross sections or profiles. Use breaklines for that
purpose, even though they do not have to be triangulated.

For details on other options, see the InRoads Online Help.
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10. <D> Apply and follow the prompts and <D> to identify the Primary, Secondary and
Reference lines.

Note: These can be either graphics or features as specified by the Locate Graphics /
Locate Features lock. Here, the POSS is the Primary Feature (where the
transverse lines are coming from), the Fill slope is the Secondary Feature (where
the transverse lines are going) and the POSS is the Reference (what the transverse
lines are perpendicular to, and where the interval is measured).

Notice in this case, you may need to add additional features to “catch” each of the vertices
in the new toe of slope.
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Fillet Features

The Fillet Features command is used to create a 3D fillet between two existing elements or
features. The result can be either a new feature or a graphic element, depending upon the
Generate Graphics Only toggle. While it can be used anytime a fillet is needed, one of the
most common uses is to create a return for a driveway. Intersection returns are typically
handled with templates. See the Roadway Modeling chapter for additional details.

Note: This command produces a 3D linestring or feature, not a true arc.

Note: The Multi-Center Curve command can also be used in this situation, creating a
horizontal and vertical alignment for the 3D return, followed by running a template for
the return.

To create a driveway fillet:

1. Select Surface > Design Surface > Fillet Features.

H Fillet Features =] & ==
Destination Surface: 12345 _SHE6 - Elevations from Destination Surface
Fiadius: 25.00 J Copy Reference Feature Paints T

Fillet Feature Reference Feature 1 —————————

Interval: 5.00 ﬂ Surface: | 12345_SHEG - | Fiter...
Stroke Tolerance: .01 M ame: |12345_SH88-LT_Hb - | ﬂ Freferences...

Mame: 85-Drive_EOP-Top? = ﬂ Offzet: 0.0o ﬂ Help

Feature Style: D_EOP — Tranzverze Slope: 0.00% J
Faint Type: Ereakline - Elevation Adjustment: 0,00 ﬂ

Duplicate Mames:

Append Replace Renarme Reference Feature 2
Exclude fram Triangulation SlikEE 12345 existing grour =
Generate Graphics Only e T_Edge of Driveway ~ ﬂ
[ffzet: 0.00 ﬂ
Extenzion Length: 0.00 ﬂ Tranzverze Slope: 0.00% J
Triangulate Surface Elevation Adjustment: 0,00 ﬂ

2. Select the Destination Surface where you want the fillet placed. In this case, it’s the
proposed model.

3. Set the Radius desired for the fillet.
4. For Interval key in 5.
5. Toggle off Stroke Tolerance.

Note: The Interval and Stroke Tolerance determine the density of the vertices in the
resulting feature.

6. Specify the Name of the feature.

Hint: If you choose a name that exists already, it will populate the Feature Style and the
Point Type so you don’t have to. You can then type over the existing name with a new one.

7. Select Reference Features 1 from the drop-down list or use the target locator button to
graphically select the feature.
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8. Repeat for Reference Feature 2.

Note: Reference Feature 1 and 2 are the features from which you are creating the fillet.
The order in which you select the features determines the direction of the resulting
fillet feature (direction is from 1 to 2).

For details on the other options, see the InRoads Online Help.
9. <D> Apply and when prompted, identify the quadrant where you want the fillet.

10. Accept with a <D>.
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Generate Sloped Surface

The Generate Sloped Surface (GSS) command can be used anywhere you need to
generate a slope extending from a known feature or graphic element to a surface. In this case, it
is used to create a sideslope for a pond.

1. Select Surface > Design Surface > Generate Sloped Surface.

’H Generate Sloped Surface == @‘
Current Locate Mode:  Features T
Source Surface: W W

Intercept —————
L SU'fECE 12345 existing graur = IM
Elevation: 0.00
Destination Surface: 12345 des pond -
Interval: 10.00 ﬂ
Cut Slope: 16.67% Tor  3300%
Fill Slope: RETE Tao  3300%
Apply to Both Sides | Triangulate Surface
Feature
Mame: Style:
V| Transverse:  pond Trans - ﬂ | DTHM_Transverse v |
Tick Marks
Source: Pond Eattam ﬂ Breakline
V| Cateh Point: pond Catch - J | H_Detention_Pand-Tap - |
Paint Type: Breakline hd
Faint Density Interval: — 0.on ﬂ
Duplicate Mames:
Append Feplace @ ]
Exclude from Triangulation Generate Graphics Only

[ Apply

] | Freferences... | |

Cloze |

Note: The Current Locate Mode is determined by the Locate Features / Locate Graphics

lock.

2. Set the Source Surface to the surface where the origin of the slope is located.

3. Set the Intercept Surface to the surface that you are intercepting with the slope.

Note: You can also tie into an elevation, such as when you want to bench the slope at an

elevation.

4. Set the Destination Surface to the surface where the slopes are placed. The surface can
exist already, or you can type in the name of a new one and it is created when you Apply.

5. Key in the values for the Cut and Fill Slopes.

Note: For the Cut and Fill Slopes, there is a percentage and a To: option. Use this when
you want to transition between two sideslopes.
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6. Toggle off Apply to Both Sides.

Note: Use Apply to Both Sides when you want slopes extending from both sides of the
feature or element, such as when you are creating a ditch.

For details on the other options, see the InRoads Online Help.

7. <D> Apply and when prompted, identify the feature you’re sloping from.

\

8. When prompted, <D> to identify the beginning point of the sideslope, then <D> again for
the ending point. Optionally, you <R> to use the entire feature, as shown here.

9. <D> to accept the sideslope on the side of the original feature where you want the
sideslopes to be formed.
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Apply Template

Apply Template basically allows you to use any MicroStation element or InRoads feature as
the horizontal and vertical control for creating a DTM from a template, without having to set up
a corridor using Roadway Designer. This is very useful, for example, when creating:

e Sideslopes from a pond or pit that are more complex than Generate Sloped Surface is
capable of producing

e  Walls created without Designer, such as the terraced walls under an interchange bridge

Bt Apply Template = (B
Design Surface: 12345 des pond -
Exterior &rc: 5000 T o |

Mirror Reflect S ——
Freferences...
Reference Feature
| Interval: 10,00 ﬂ He—llp
Stroke Tolerance: | 1.00
Templates:
25 C:AProjectst] 23455D esigntInFoadsh\COOT_Template-Libr « Ll
23 1 - Templates

= 12345_HMa_2Laneleft Side
= 12345_HMa_4Lane
== COMC_4Lane_Right-Side_Only
e COMC_Divided_Typed,_d4Lane
= COMC_Ramp
e HMA,_Crowned_B10
== HMA,_Divided_Typed_4Lane
== HMA,_Full_Depth_'widening_2Lane
== HMA_Urban_4Lane
= Scab-On Detour
[Z3 2 - Sections - Pavement =
4 = n 3

m

Features
Duplicate Mames:
Append Replace @ Rename M odify

| Remove Loops Generate Graphics Only

| Triangulate Surface

While the same templates can be used for Roadway Designer’s Template Drops and the
Apply Template command, keep in mind that Apply Template cannot transition between
different templates or use any of the other advanced modeling options available in Designer
such as Point Controls and Parametric Constraints.

In this example, a pond is being modeled from a known bottom (created previously with
Generate Longitudinal Feature). The sideslope of the pond is set to slope up to a certain
elevation, berm and then proceed in cut until interception with the existing ground.

Note: Most CDOT end condition templates are created with the Target listed as Active
Surface. If this is the case for the template being used with Apply Template, be
certain the correct surface is active before Applying.

1. Select Surface > Design Surface > Apply Template.
2. Toggle off Generate Graphics Only, or the command will not create features.

3. Specify the Design Surface.
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Note: The Design Surface is where the resulting features are placed, not the target
surface for the template.

4. Toggle off Mirror and Reflect.

Note: The direction of the graphic or feature determines the direction the template is run.
If necessary, you can reverse the direction (for a graphic, use Change Element
Direction; for a feature, use Reverse Feature Direction) or you can Reflect
the template. If you want to run the template down both sides of the graphic or
feature, select Mirror.

5. Select your template from the library and set the other options as shown.
For details on the other options, see the InRoads Online Help.

6. <D> Apply and identify the graphic or feature the slopes are coming from (in this case,
the pond bottom).

Note: You are prompted based on your Locate Graphics / Locate Features toggle for
cither a Primary Element or a Primary Feature.

7. <D> on the bottom of the pond to identify it as the Primary.
8. Next, you are prompted for the Reference. <D> on the bottom of the pond as the reference.

Note: The template is applied perpendicular to the Reference, and the interval is applied
to the Reference. In this case, the bottom of the pond is both the Primary and the
Reference. An example of when they might not be the same is when you are
applying the template to an edge of pavement, but you want the results
perpendicular to the centerline alignment.

9. You are then prompted to identify the beginning (and subsequently the end) of the pond
bottom or if you Reset <R>, the entire feature is used. In this case, <R> to identify the
entire pond bottom. Notice also there is tracking so you can see the direction of the feature.

10. <D> to accept the solution and the sideslopes are created.

Note: When the Triangulate Surface option is toggled on, the features created by Apply
Template are incorporated into the triangulated DTM.

11. View the triangles or contours to see the results.
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Project Line to Surface

The Project Line to Surface command is useful when you need to know where a certain
slope intercepts a surface before creating a sideslope. It can also be used for line-of-site studies.
The input for the command is a MicroStation graphic to start from and the result of this
command is a MicroStation line; no features are used or created.

’H Praject Line to Surface [=] = @‘
Surface: |12345 exigting grour v| | Anply \
Slope:  1G.67% #| ™ oo
V| Dynamics

Help

1. Select Surface > Design Surface > Project Line to Surface.
2. Set the Surface to the one you want to intercept.

3. Key in a Slope of the resulting line.

4. Toggle on Dynamics.

5. <D> Apply.

6. When prompted, snap to the element you’re sloping from.

Note: In the direction defined by the location of the cursor, a line extends until it
intercepts the given surface. A <D> creates the line as an element. If you want to
come from the same point in a different direction, you can continue to move your
cursor and <D> wherever necessary.

In this case, multiple points are checked along the element to see where the slope
intercepts. The endpoints of these lines could be joined with a linestring and loaded as a
feature for the toe of slope, or you can now use Generate Sloped Surface to create the
features after identifying the desired slope with the Project Line to Surface command.
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Resurface

The Resurface command is useful when you need to define features for a resurfacing project
that ‘clear’ the existing surface plus a minimum lift. Using the Maintain Cross Slope — Both

Lanes toggle, the features are created so that when the existing cross slope on each side of the
roadway is maintained, the new features form a surface that is the lift-height above the closest
orthogonal point to the new surface. In order to use this command, you must have features for

the existing centerline and pavement edges.

H Resurface EI E] @
Design Surface: 12345 resurface - [
| Empty Design Surface Cloze

Duplicate Mames —
Append Fieplace Fiename I&I

Existing Surface: m

Left Edge Feature: W ﬂ
Centerline Feature: W ﬂ
Right Edge Feature: W ﬂ

Minirnurn Lift: 067

Maintain Cross-Slope
@ Both Lanes Highest Lane

Resurface is an Application Add-In that must be toggle on prior to use. Select Tools >
Application Add-Ins and toggle Resurface on if you don’t initially see it on your menu.

1. Select Surface > Design Surface > Resurface.

2. Set the Design Surface to the surface where you want the new features to be created.

3. Set the Existing Surface to the surface where the current features for the Centerline, Left

and Right Edge features are located.

4. Key in the minimum lift.

For details on the other options, see the InRoads Online Help.

5. <D> Apply to create the new features.
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At each vertex along the centerline feature, the current cross slope is measured, the highest
orthogonal distance from that cross slope is determined, and new features are added so that
the same cross slope can be maintained along with a minimum clearance between the
existing surface and new cross slope equal to the lift value.

Lift = minimum New Features

clearance

g \ Existing Features /

Existing Ground

Since there are no components added to the proposed surface using this command, the real
value comes from using these new features as controls when creating a model using Templates
and Roadway Designer. See the Typical Sections and Roadway Modeling chapters in this
guide for additional information.

Section Summary:
e Design surfaces do not have to be created from Roadway Designer alone.

e Commands that create features allow you to enhance a surface created with other tools or
create a new surface from scratch.

e Templates can be used with surface manipulation commands without using Roadway
Designer or setting up corridors.

e Features resulting from these commands can be used in combination with Roadway
Designer, such as for Point Controls or horizontal and verticals control for a corridor.
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Modifying Features

There are many options within InRoads that assist in manipulating design models by changing current features.
These tools are used when creating surfaces from scratch, such as ponds or parking lots, or when modifying
previously created models such as roadways developed with Roadway Designer.

Section Objectives:

e To be able to modify horizontal and vertical locations of existing features.

e To develop an understanding of when each of the feature editing commands should be
used.

e To learn techniques that refine existing surface models by modifying features.

Accessing Edit Surface Commands

While there are many commands in InRoads that modify features, several of them are grouped
under Edit Surface. You can access them from the Surface > Edit Surface pull-down
menu, or from the Edit Surface toolbar. Most are described in the following section.

Edit Surface =]
AR A FK A DFEAGE S8

IMenu Bar =
File | Suface Geometry Drainage Evaluation Modeler Drafting Tools Help

Wiew Surface 3
ﬁ Update 3-D/Flan Surface Display...
Fit Surface

& Iriangulate Surface...

Design Surface 3
Dresign Pad +
Edit Surface L\\, f{ LCopy Single Feature. ..

4 ;f(: Edit Feature Point...
,,><.‘ Delete Feature Paints...
" Divide Feature. .

Feature

B Surface Properties...

B Active Surface... A Reverse Feature Direction
:‘: LCopy Surface... Z( Delete Feature. ..
B Delete Surface. . 3 Patial Delete
g Bename Surface... H Break Feature
Utilties b H Join Features
2% Trim Features. .

/3\ Extend Features...

A Intersect Features. ..

Q”'j Copy Portion of Surface...
@I Transform Surface...

erge Sufaces. ..

B4 Delete Triangle...
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Generate Longitudinal Feature

Generate Longitudinal Feature (GLF) is used to create and/or modify 3D MicroStation
elements or features in a DTM. It is an extremely powerful tool that allows much easier
manipulation in 3D than MicroStation alone.

H Generate Longitudinal Feature =] & ==
Main | Cartrols
Surface: 12345 des pond - Filter...
Exterior &rc: 5000 o
Mew Style...
Reference Feature —————
| Interval: 10.00 ﬂ I&I
Stroke Tolerance: | 0,01
Longitudinal Feature
Mode: Mew @ Modify
Fond Berm J
Breakline
Breakline
0.00 #|
Append Fieplace ) Rename
Ewxclude from Triangulation
Femove Loops Generate Graphics Only
Triangulate Surface
[ Apply ] | Freferences... | | Cloze |

When using this command to modify existing features, several of the options are not available,
as they are already set for the feature (such as Name, Style, etc).

For information on using GLF, see the Generate Longitudinal Feature topic in the
Creating Features section of this chapter.
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Set Slope Along Feature

The Set Slope Along Feature command is used when you need to modify elevations of
points in a feature by defining a slope along the feature, but you do not want to modify the XY
location of any of the points. For example, use this command when you need to ensure a drain
line slopes to a low point on the feature.

’H Set Slope Along Feature == @‘
Feature: 12345 SHEGDiive_EO ﬂ Cioee
Filter...
Help
Back Paint Target
Paint: El? 3 of 29 El@ ﬂ Lack
I . =
Northing:  1556445.18 Paint: ()12 of 28 ]G 4
Easing:  3278078.44 Morthing: 1556440.00
Elevation 5624.11 Easting: 327889776
Elevation: EE21.00 ﬂ v
Ahead Point ——
int: (1<) =i %
Paint: M |22 of 29 uul ﬂ X J
Morthing: 155641645 20.00 #|
Easting: 327892768 8.20% #|
Elevation 562510 50.00 #|

In this example, a low point is needed in the middle of a return.
1. Select Surface > Set Slope Along Feature.
2. Set the Surface to the surface containing the feature you are changing.

3. Select the Feature from the drop-down list, or use the Locate button to select the feature
graphically.

For this example:
4. Set the Back and Ahead Points to the points you want to hold constant.

5. Set the Target to the point you want to assign a new elevation.

Profile of feature

G—6—6—6—0{}-GG—G—-G—GG-GG-G—Q—G*O—-G—G—O-G-G—O-—-G—G—G-G-G

Back Point Target Ahead Point

6. 1In the Target section, toggle on Lock for the Point and Elevation and key in the elevation.

Note: When setting the target, you have the option of locking two of several inputs to
create the desired results. In this case, we want the Target Point locked (so a new
point is not created), and we want the Elevation locked for that point. All points
between the Back and Ahead are adjusted in elevation to accommodate the
modified point.
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7. <D> Apply to modify the feature.

Profile of feature

e—eeeeeeeﬂ\ﬁﬁﬂ 000000000000 000600
o B,

Back Point Tafget Ahead Point

For details on using the other Target options, see the InRoads Online Help.
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Drape Surface

Drape Surface is used when you want to force a graphic element or a feature (based on the
Locate Graphic / Locate Feature toggle) to take on the elevations of an existing DTM. This
command increases the number of vertices, since not only are the original vertices assigned the
elevations of the surface, but a vertex is added everywhere a triangle is crossed. The exception
is when Drape Vertices Only is on, in which case only the original vertices are assigned new

elevations.

HDrape Surface El = @
Current Locate Mode: Graphics
Destination Surface: W o

Graphics o
Input Made: |S|ng|e—v| Filter...

4LG_COGO_Paints ( Preferences. |
Destination Level: |41 5 COGO_FPaints Help

Delete Original Graphics

Features

12345 exizting ground

Mame Style Drescriptiol J
4 n 3
Scale: 1.0000
Elevation Adjustment: 0.00

Dirape Yertices Only

The Destination Surface determines the elevations and is where the new feature is created if
the Destination and Features Surfaces are not the same. (If they are the same, the feature is
modified.)

In the following example, the outer perimeter of a pond is known, so to begin modeling the
pond, this perimeter must first be draped onto the existing surface. If the perimeter was draped
as a feature, it would then reside in the existing surface model. Since the pond is modeled in a
separate surface, it is draped as a graphic, then imported.

1. Set the Locate Graphics / Locate Features toggle to Locate Graphics.

2. Draw the perimeter of the pond with MicroStation if it doesn’t already exist.
3. Select Surface > Design Surface > Drape Surface.

4. Set the Input Mode to Single.

Note: You can use a Level or Fence from the drop-down. You can also use a
MicroStation selection set by having it active first, then choosing Single.
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5. Toggle off Destination Level and Delete Original Graphic.

Note: If Destination Level is toggled on, the new draped graphic is created on that level.
If not, it is created on the level of the original graphic, which may or may not be
deleted based on the Delete Original Graphics toggle.

6. For Scale key in 1.

Note: The Scale is used to exaggerate the display of the results. It does not affect the

actual elevations if creating a feature.
7. For Elevation Adjustment key in O.

Note: Elevation Adjustment is used when you want to add or subtract a set amount from
the elevation of each vertex. For example, you can use this to drape an
underground utility to 6° below the existing ground.

8. <D> Apply and <D> on the graphic to drape.
9. <D> to accept the results and the new graphic is created.
Important!  If you want to drape a feature onto one surface but have it placed in another,

you can use the Drape Vertical option in Generate Longitudinal Feature
or Import Surface from Graphics with the Drape option.

The draped graphic may now be imported or used with either Generate Sloped Surface or
Apply Template.
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Edit Feature Point

Edit Feature Point is useful when you need to edit or delete one vertex of a feature at a time.
For example, if you have a spike in a surface caused by a zero-elevation point that was
accidentally included in a breakline, use this command to delete it.

1. Select Surface > Edit Surface > Edit Feature Point.

’H Edlit Feature Point EI El @‘
Suface: (12345 5Hes - Apply

Feature: (12345 sHagDrive EOP-Top v | 4] [ Cose |
Port  [klxJ1z  of 28 ([ 4 [Linsen | [ Fiter.. |

Center View  Delete |
Nerthing: 155643671 o E——
Easting  3778902.59 + (e |
Elevation: ggz4 57 ﬂ IM

Start of Digcontinuity

2. Set the Surface to the surface that contains the feature you want to edit
3. Select the Feature that you want to edit.
4. Select the feature Point that you want to edit.

Note: You can step through the points, or you can use the Locate button to choose the
point graphically. When the point is active, there is a target symbol identifying it in
the MicroStation view. If the Center View option is toggled on, MicroStation will
center the current view on the selected point.

5. Change the Northing, Easting and/or the Elevation by keying in new values or by using
the appropriate Locate button and setting the values graphically.

6. Select the More >> button to access additional options for setting the location of the active
point. These options are similar to those found on the Set Slope Along Feature
command.

Note: You can edit more than one point in a feature before you choose Apply, but changes are
not made in the surface or reflected graphically until you do.

7. <D> Apply to edit the point(s).

For details on the other options, see the InRoads Online Help.
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Delete Feature Point

The Delete Feature Point is useful when you want to delete Random points in a DTM that
are outside of an elevation range. For example, if you have several points with a zero elevation,
you can use this command to get rid of them all at once without having to find and delete them

individually.
H Delete Feature Points =] & ==
Surface: 12345 existing grour +
lgnare Clase
Random Features:
Filter...
Mame Style [es * ﬂ I—I
T_Edge of Dil354 T_Edge of Ol Edge Izl
T_Edge of Oil415 T_Edge of Oil Edge Hel
p
T_Edge of Oil416 T_Edge of Oil Edge I—I
T_Edge of ‘Wetlands Ciw T_Edge of ‘Wetlands C  Edge
T_Edge of ‘Wetlands Cw176  T_Edge of Wetlands C' Edge
T_Edge of ‘Wetlands C'w/325  T_Edge of Wetlands Cw/'  Edge ~
4 1 [3

Fiange To Keep
Low. 515000 +|

High:  1pooo.oo +|

Note: The features containing the points that are out of the Range to Keep specified must be
highlighted before choosing Apply. Only Random point features are shown in the
dialog, and you can use Feature Filters to further limit the features shown.

Reverse Feature Direction

The Reverse Feature Direction command is very much like the Change Element
Direction command in MicroStation. It is useful when you have a feature running in one
direction and you would like it to run in the other. For example, if you are using the feature for
the horizontal and vertical control in a corridor (in place of a horizontal and vertical alignment)
and the feature was built in the opposite direction you want your model created.

1. Select Surface > Edit Surface > Reverse Feature Direction.
2. When prompted, <D> to identify the feature.

3. Once highlighted, the name of the feature is shown in the message field and you can Accept
<D> or Reject <R> the feature. Reject it and the next closest feature is highlighted for you
to Accept or Reject.

Note: There is no dialog box for this command, so be sure to read the prompts.
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Delete Feature

The Delete Feature command allows you to remove one or more features from a surface. In
the dialog box, the list of features is controlled by the Feature Filter lock, so you can segregate
out just the features you want to see, if necessary.

H Delete Feature El =] @
Surface: 12345 despond v
lgnare Clase
Features: ————————
Filter...
Mame Style Description ﬂ I—I
Pond Berm H_Detention_Pond-Battom Created by &) Results...
Pond Berml H_Detention_Pond-Battom Created by &) Help
Pond Bottom H_Detention_Pond-Battom
Pond Battom1 H_Detention_Pond-Battom Created by &)
Pond Catch H_Detention_Pond-Top Created by &)
Pond Catchl H_Detention_Pond-Top Created by &)
4 m 3

1. Choose Surface > Edit Surface > Delete Feature.

Note: Ifthere is a fence active, you can choose from Ignore, Inside or Qutside options.
These modes act like the Clip option in MicroStation. If a feature extends out both
sides of the fence, using the Inside option results in a feature with a gap.

2. In the feature list, <D> to highlight the feature or features you want to delete. <R> on the
list for a menu that allows you to Select All, Select None or Invert Selection.

H Delete Feature =] & ==
Surface: 12345 despond v
lgnare Clase
Features: ————————
Filter...
Mame Style Description ﬂ I—I
Pond Berm H_Detention_Pond-Battom Created by &) Results...
Pond Berml H_Detention_Pond-Battom Created by &) Help
Paond Battam H Detention Pond-Bottom
Pond Batton L\\) Select All Ctrl+A Created by 2
Fond Catch Select Mone Ctrl+M Created by 2
Pond Catch| Created by &)
Invert Selection |
4 2

[o]

Note: Select All can be accessed with <C7RL=> A and Select None with <CT7TRL> N
without right-clicking.

3. <D> Apply and the feature or features selected are deleted from the surface.

4. Select Results to see how many feature points were removed with the action. (Results will

only show points deleted from Random, Breakline and Interior Features, even though other
types may be deleted.)

Note: If you want to delete all the features in a surface, <R> on the surface in the Explorer
portion of the InRoads menu and select Empty.
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Partial Delete

The Partial Delete command works much like the MicroStation Partial Delete, except it
works with features. The MicroStation display of the feature is also updated if it was originally
displayed in Pencil Mode.

1. Select Surface > Edit Surface > Partial Delete.
2. When prompted, <D> on the feature to identify it.

3. <D> to Accept the feature or <R> to Reject the feature when it highlights and its name
appears in the prompt field.

4. <D> on a Starting point for the delete.
5. <D> on an Ending point for the delete.

The results are one feature with a gap where you partially deleted it. To make two features out
of the gapped feature, see the following Break Feature command.

Note: There is no dialog box for this command, so be sure to read the prompts.

Important!  When you Partial Delete a feature, a point is added at each end of the delete.
If you want to only retain original points in the feature, turn the Snap lock to
Point Snap and the starting and ending points of the deletion are forced to fall
on existing vertices.

Break Feature

Break Feature quite simply make two features out of one. The second feature has the same
name as the first with a counter appended on the end. This command does not leave a gap, but
rather leaves the two features with a common point where they meet. If the feature already has
a gap, you can break the feature at either end of the gap to get two features.

1. Select Surface > Edit Surface > Break Feature.
2. <D> the feature you want to break.
3. Accept <D> if the correct feature name is shown, Reject <R> if not.

4. Once the feature is accepted, a tracking line is displayed from the feature to your cursor.
Locate the point where you want to break the feature and <D>.

Note: There is no dialog box for this command, so be sure to read the prompts.

Important!  When you break a feature, a point may be added to each feature at the break
point. If you want to only retain original points in the feature, turn the Snap
lock to Point Snap and the break point is forced to fall on an existing vertex.
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Join Features

The Join Features command is very similar to the MicroStation Create Complex Chain
command. It allows you to select two or more features to combine into one. Where it differs
from the MicroStation command is in how the features are accepted. In MicroStation, you can
select that next line with the accept of the current one. In joining features, you much select and
accept each feature before moving on to the next one.

Use the Join Feature command when you want to combine more than one feature to use as
the basis of a Roadway Designer Corridor, the Apply Template command, or as a target for
an end condition, for example.

1. Select Surface > Edit Surface > Join Features.

2. <D> on the first feature, and <D> again to accept if it is the one that highlights and whose
name is listed in the prompt field.

Note: The first feature selected determines the name of the resulting combined feature.
3. <D> on the second feature and <D> again to accept.
The second feature is deleted as it becomes part of the original feature.

4. Continue to identify features and accept them until you have all the features you want
combined.

Important!  When the feature do not touch, they are joined with a straight line closure. If
the features overlap, they will still overlap after combining (i.e. they are not
trimmed automatically). Since overlaps may cause DTM tolerance problems
when triangulating, you can Trim or Partial Delete the features prior to
joining. For more information about these commands, see their sections in this
chapter.
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Trim Features

The Trim Features command is similar to the Trim command in MicroStation. It allows you to
trim a single feature or groups of features based on a cutting feature or cutting element. You can
use Trim Features after combining features from different models where there is overlap, for

example.

L.

H Trim Features
Current Locate Mode:  Features
12345 existing grour

Surface:

Features:

Select Surface > Edit Surface > Trim Features.

ol e =
Cloge

Mame Style

T_Edge of " ater:Rivers T_Edge of " ater..
T_Edge of “Water:Rivers753 T_Edge of " ater...
T_Edge of "W ater:Rivers755 T_Edge of " ater...
T_Edge of "W ater:Rivers759 T_Edge of " ater..
T_Edge of "W ater: Streams T_Edge of " ater..
T_Edge of ‘etland T_Edge of ‘Wetla...
4 m

Descriptio

. Edge of '

Edge of '
Edge of '

. Edge of '
. Edge of '

3

+|  Fiter..
Help

-

Elewation

@ Do Mot Change Match at Intersection

Mode

@ One Section To One Side

Note: Notice the current Locate Mode, which is controlled by the Locate Graphics / Locate
Features lock. This determines whether you can identify a graphic element or a feature

as the cutting element.

2. Select the Surface where the features reside.

Note: Ifyou are clipping with a feature, it must reside in the same surface. If it does not,
you can display it graphically, then use the Locate Graphics toggle.

In the feature list, highlight one or more features using the <Shift=or <Ctr/>keys

when necessary. <R> on the list for a menu that allows you to Select All, Select None or
Invert the current selection. (You can use Feature Filters to narrow the list of features.)

Note: Select All can be accessed with <CT7RL> A and Select None with <CTRL> N

without right-clicking.

4. In the Elevation section:

¢ Select Do Not Change when you want all features to retain their original elevations.

¢ Select Match at Intersection when you want the feature being clipped to adjust their
elevations at the clip point to match that of the clipping feature or element.
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5. Select one of the Mode options. The Mode refers to how many trims you want to make on
each feature.

¢ One Section is typical, when you want to trim the end of a feature back to another.

h Trim Features E = @
Curient Locate Mode:  Features
Gurtace: 12345 existing grour -

Close
Filter....
MHame Style Descriptio ﬂ
T_Edge of Water>Rivers T_Edge of Water... Edge of W

T_Edge of “Water>Rivers?53 T_Edge of Water... Edge of W
T_Edge of “Water:Rivers755 T_Edge of Water... Edge of W
T_Edge of ‘W ater:Rivers759 T_Edge of Water... Edge of '

T_Edge of Water>Streams T_Edge of Water... Edge of W
T_Edge of Wetland T_Edge of Wetla 57
] i +
Elevation

@ Do MNat Change ' Match at Intersection

Mode

@ One Section ~' To One Side

Trim Features One Section

/‘v‘ o= . -\ it = /l"j_j--,,_‘f_-h-'_—'-

¢ Use To One Side when you want to only keep the portion of a feature that is on one
side of another. For example, if you have a wetland feature and a ROW feature that
overlap back and forth, and you’re only concerned with the wetland if it’s inside of
your ROW. Highlight the wetland feature in your feature list, then identify the ROW as
the clipping feature. With the mode set to To One Side, you’ll be able to keep all parts
of the wetland that are on one side of the ROW.

h Trim Features E = @
Curient Locate Mode:  Features
Gurtace: 12345 existing grour -

Clogze
Filter....
MHame Style Descriptio ﬂ
T_Edge of Water>Rivers T_Edge of Water... Edge of W

T_Edge of “Water>Rivers?53 T_Edge of Water... Edge of W
T_Edge of “Water:Rivers755 T_Edge of Water... Edge of W
T_Edge of ‘W ater:Rivers759 T_Edge of Water... Edge of '

T_Edge of Water>Streams T_Edge of Water... Edge of W
T_Edge of Wetland T_Edge of Wetla 57
] i +
Elevation

@ Do MNat Change ' Match at Intersection

Mode

) One Section @ ToOne Side

Trim Features To One Side
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6. <D> Apply and select the clipping graphic or feature.
7. <D> to Accept the clipping graphic or feature.

8. <D> on the side you want to delete.
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Extend Features

The Extend Features command is similar to the Extend Line command in MicroStation. It
allows you to extend a single feature or groups of features until interception with another
feature or graphic element.

HExtendFeatures =] & ==
Surface: 12345_SHEG -
Features:

Cloze
Mame Style Description - ﬂ

Filter...
HMA_Lift3Centerlin... Centerine Created by roadway ... ILI
H_Channel H_Channel Help
H_Channell H_Channel
H_Channel2 H_Channel
H_Channel3 H_Channel
LT_ABC_EOP-Top  D_EOP Created by roadway ...
LT_ABC_Hinge-Top D_HIMGE Created by roadway ... ™
Elewation
@ Do Mot Change Match at Intersection

1. Select Surface > Edit Surface > Extend Features.

2. Select the Surface where the feature(s) you are extending reside. If you are extending to a
feature, it must reside in the same surface. If it does not, you can display it graphically, then
use the Locate Graphics toggle.

3. In the feature list, highlight one or more features using the <SA/ft=or <Ctr/> keys
when necessary. <R> on the list for a menu that allows you to Select All, Select None or
Invert the current selection. (You can use Feature Filters to narrow the list of features.)

Note: Select All can be accessed with <CTRL> A and Select None with <C7RL> N
without right-clicking.

4. In the Elevation Section

¢ Select Do Not Change when you want the features to extend at the same slope as the
last segment of the feature.

¢ Select Match at Intersection when you want the feature being extended to match the
elevation of the feature or element to which it’s being extended.

5. <D> Apply and select the graphic or feature to which you’re extending.

Note: The Locate Graphics / Locate Features lock determines whether you can identify a
graphic or a feature.
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6. <D> to Accept the graphic or feature.

Features Before Extension Features After Extension

’
’/
/

= uie

[

§
‘N
L

Intersect Features

The Intersect Features command is similar to the Extend Elements to Intersection
command in MicroStation. It allows you to extend two features until they intercept, and
optionally change the elevation of the second to match that of the first at the intersection point.

E Intersect Features

Feature 1 Apply

==
Surface:
Filter...
Feature 2 -—
Help
Surface:
4|

Elewation
(") Do Mot Change @ Match at Feature 1

1. Select Surface > Edit Surface > Intersect Features.

2. Select the Surfaces and Features you are intersecting. If you are not matching elevations,
the order does not matter.

3. <D> Apply.

4. You are prompted to accept the intersection to keep. If there is more than one intersection,
you can move your cursor to see additional intersections and <D> to keep the one you
want.
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Delete Triangle

The Delete Triangle command allows you to delete one or more triangles from a surface. It is
useful when the triangulation routine creates triangles that you do not wish to keep. Sometimes,
this is most obvious when creating contours which are derived from the triangles.

1. Select Surface > Edit Surface > Delete Triangle.

’E‘ Delete Triangle E”E“

Surface: [SH52 Flst intersecti '] [ Apply J

2. Select the Surface where the triangles exist.

3. <D> Apply.

If you are deleting one triangle:

4. <D> on the same triangle twice, and <D> to Accept.

If you are deleting a series of adjacent triangles:
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5. <D> on a starting point and move the cursor, drawing a line across the triangles you want
to delete.

6. <D> to end the selection.

7. <D> again to accept the highlighted triangles as the ones to delete.

Note: The triangles do not have to be displayed. When you select them, they highlight. If you
drag the cursor across a series of triangles, they are temporarily displayed; only the
highlighted ones when you accept are actually deleted.

Important!  If you delete triangles and the surface is re-triangulated, the triangles are re-
created. To make certain the deletions are permanent, you can either add an
exterior if the triangles are on the edge of the model as shown in this example,
or add an interior if they are on the inside.
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Copy Portion of Surface

The Copy Portion of Surface command is for copying features from one surface into
another. You can combine two surfaces by copying all features, or you can selectively choose
features to copy.

H Copy Portion of Surface

Source Surface:

Features:

lgnare

12345 Design pond -

Destination Surface: 12345 Combined

-

Mame

Pond break4
Paond breakb
Paond break?
Paond break
Paond breakd
Pond drain

Pond top

Style
Breakline
Breakline
Breakline
Breakline
Breakline
Breakline
Default

Description

Created by Generate ...
Created by Generate ...
Created by Generate ...
Created by Generate ...
Created by Generate ...
Created by Generate ...
Created by Generate ...

m

Duplicate Mames:
Append

Feplace

@ Rename

ol e =

#

Apply

Cloze

fek

Filter...

Results...

]

Help

When copying an exterior from one surface to another, keep in mind there can only be one
exterior in a surface and the last exterior added will be the exterior used in the surface.

1.
2.

Select Surface > Edit Surface > Copy Portion of Surface.
Specify the Source Surface where the feature currently resides.

Specify the Destination Surface where the features are going. If the surface does not exist,

you can key in the name and it will be created when the command is applied.

In the feature list, highlight one or more features to copy using the <Sh/ift=or <Ctr/>
keys when necessary. <R> on the list for a menu that allows you to Select All, Select None
or Invert the current selection. (You can use Feature Filters to narrow the list of features.)

Note: Select All can be accessed with <C7RL=> A and Select None with <CT7RL> N
without right-clicking.

5.

<D> Apply to copy the features.

For details on other options, see the InRoads Online Help.
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Merge Surfaces

The Merge Surfaces command combines two surfaces. It is most useful for creating an ‘as-
designed’ model, since it removes the portion of an Original surface that overlaps a Design
surface. After using this command, you can create contours for the combined model showing
what the surface should look like after the design is built.

H Merge Surfaces =] & ==
Original: 12345 existing grour + —
L ———————————— Cloze
Design: 12345_SH35 v
Destinatiar: 12345 ex and SHEE [ Fiter. |
Freferences...
Fietain All Original Surface Points T
elp

Fietain Features Excluded from Triangulation
| &dd Design Surface Edge az Breakline

Included Design Suface Features

Mame Style Description i ﬂ
ABC_Centerlline-Top  Centerline Created by roadway ...
D_'wallwfing D_'wallwfing

Exterior Boundary Exterior Boundary  Created by roadway ...
HiA_Lift_Centerlin... Centerline Created by roadway ...
HMA_Lift2_Centerlin... Centerline Created by roadway ... i
UkdA 10D ek r. kel Crmmbmd by A

Duplicate Mames:
Append Replace @ Rename

1. Select Surface > Edit Surface > Merge Surfaces.
2. Specify the Original and Design surfaces.
3. Specify the Destination Surface where the combined model is created.

Note: If the surface does not exist, you can key in the name and it will be created when
the command is applied. While you can replace the existing surface with the
combined, it is not recommended.

4. <D> Apply and the surfaces are combined and the resulting merged surface is triangulated
as shown in these before and after cross sections.

Cross section of original surfaces
- SH 86

existing ground

Cross section of resulting surface merged surface

For details on other options, see the InRoads Online Help.

Note: Multiple merges typically begin to bog down the surface. This is not a good option for
combining several surfaces, such as for the different models that may be created in
designing an interchange. Use either Copy Portion of Surface or run multiple
corridors at once with Roadway Designer.
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Resolve Crossing Segments

The Resolve Crossing Segments command assists in correcting crossing linear features in
a surface. When two linear features cross at the same elevation, a point is assumed at the
crossing and the surface triangulates as normal. When the features cross but at different
elevations, the software cannot triangulate the area since triangles cannot cross linear features.
This command resolves those situations.

H Resalve Crossing Segments =] & ==
Surface: 12345 existing grour -
lgnare Cloze
Delta Talerance:  {.0g ]
Filter...
Method
Results...
Feature Fiker: | |1 mameds Preferences. .
Match Elevation: Help
@ High Low Median

1. Select Surface > Utilities > Resolve Crossing Segments.

Key in the Delta Tolerance. This is the maximum difference in elevation you allow this
command to correct. Anything larger and the crossing will be reported as unresolved.

If you have several crossings and there is a dominant feature or features, you can create a
Feature Filter, toggle on Use Dominant Feature and select it from the list.

For example, if you have several drives that cross edges of pavement, you can set up a filter
to filter everything but the edge of pavement features. In that case, anywhere there is a
crossing within the specified vertical tolerance, the crossing is resolved by adding a point at
the elevation of the edge of pavement.

Select one of the Match Elevation options.

Note: If the crossing does not involve an edge of pavement, or if it involves two edges of
pavement, the Match Elevation toggle controls, forcing the new point to take on
the elevation of the High feature, Low feature, or the Median elevation between.

<D> Apply and the crossing segments that meet the Delta Tolerance criteria are resolved.

Select Results to see a report of which feature crossings were resolved and which were left
unresolved.

For details on other options, see the InRoads Online Help.

Note: Ifthe crossing features are in an existing ground surface, you should report the problem
to the Survey group for correction.
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Generate Grade Contour

The Generate Grade Contour command is a great tool for finding a path down a sideslope
that meets a certain longitudinal grade. For example, if you need to create a haul road into a pit
or an access road down a sideslope and you are required to meet a certain longitudinal grade,
this command helps designate the path.

Here, it is used to traverse the sideslope of a pond, helping define the path of an access road.

1.
2.

Generate Grade Contour is an Application Add-in, so toggle it on before starting.

Select Surface > Utilities > Generate Grade Contour.

’H Generate Grade Cantour [= = @
Surface: 12345 Design pond = | [ Apply ]
Elooe) -3.00% Close
Maximum Distance: 50 oo ﬂ Help
Directior: 5 E5 254" E ﬂ

| Dynamics

Select the Surface from the drop-down.

Key in the longitudinal Slope desired.

Key in the Maximum Distance for the path created.

Key in (or use the Locate button to define) the starting Direction.

Note: The direction does not actually define a fixed direction for the resulting path. It just
lets the command know the general direction you want the path to take (i.e. to the
right or left around the pond in this example).

Toggle on Dynamics to see the path before accepting it.
<D> Apply.

Move your cursor along the slope and a path dynamically follows.
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10. <D> where you want the path to start.

The result is a 3D MicroStation linestring that follows the defined longitudinal slope, traversing
the surface selected. Vertices are created for the linestring at each crossing of a triangle. You
can now import the graphic as a horizontal and vertical alignment using File > Import >
Geometry from Graphics, refine the alignments as necessary, and use them in Roadway
Designer to create the access road.
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Compress Surface

When working with features in a surface, you are often deleting portions of features or deleting
points in features. These points are marked for deletion in the surface and are no longer
triangulated, but are not actually removed from the surface. Since they cannot be recovered,
they are taking up space and memory unnecessarily and should be periodically removed from
the surface using Compress Surface. This command not only removes points that have been
deleted with surface editing commands, but also removes any duplicate Random points, or
Random points that are duplicates of other type points.

’H Compress Surface =& @‘
Suface: (12345 Designpond | [ appk |
Results Cloge
Faints Removed: 356 Help
Mare. .

1. Select Surface > Utilities > Compress Surface.
2. Select the Surface you want to compress from the drop-down menu.
3. <D> Apply and the points are removed.

Section Summary:

e Features can be manipulated within a surface using tools similar to MicroStation editing
tools.

e Point elevations, slopes of features and location of features or individual points can all be
modified.

e There are tools available for modifying features one at a time, and also for modifying
groups of features.
Chapter Summary:

e Create and Edit feature tools allow you to design surfaces that do not fit the mold of a
typical section following a horizontal and vertical alignment.

e Using these tools with surfaces created by Roadway Designer allow you to refine and
enhance your designs that do fall into the category of templates following a horizontal and
vertical alignment.

e Using each InRoads Surface Creation or Surface Editing tool for what it does best allows
you to be more efficient in your design process.

e The Surface Creation and Editing tools can be an integral part of the CDOT design process
when used to their full potential.
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